Pomona Drag Strip 4 FSX !

Pomona Drag Strip 4 FSX  Top Fuel Railer’s –

This slideshow requires JavaScript.

Pomona Drag Strip 4 FSX is compatible with Microsoft Flight Simulator X SP2, Acceleration, and Steam FSX

System Requirements
Intel® Core™ 2 CPU 6700 @ 2.66 GHz or equivalent, or better
4.00 GB memory or greater
NVIDIA GeForce GTX 560 Ti Graphics card or better
Windows 7 64 or newer

Click Here to get Pomona Drag Strip 4 FSX

Click here to download these freeware dragsters for Pomona Drag Strip 4 FSX !: